BE: Raptor problem - Paintball Forum - Paintball guns and gear forums

Reply

Old February 23rd, 2006, 06:26 PM   #1 (permalink)
 
Join Date: Feb 2006
Posts: 4
BE: Raptor problem

Hi folks, nice forum here.


I have a question on how to fix my raptor I screwed up. What happened was after it was messing up on me when I was in the middle of a paintball fight in with my neighbor in his front yard, haha. I took it apart to look at it. Well, after I figure out you cant take the damn thing completely apart anyway, I got to put the thing back together. Everything is assembled, I screw the c02 tank in and i get a continuous feed of gas out of the gun.


What I am wanting to know is what is it that is wrong, and how do I fix it. I dont know much about the insides of a paintgun, but now its time I learn. I'm thinking its something that got loose that is supposed to trap the gas as it comes into the gun, only goes off when the trigger is pulled.


Any help appreciated.

thanks,
-Ryan
Ryan87 is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old February 23rd, 2006, 07:53 PM   #2 (permalink)
 
Join Date: Oct 2005
Posts: 837
okay well, find where the leak is coming out of.(should be pretty obvious) then oil that o-ring. if that doesn't work, then replace that o-ring and lube it up good. and the best way to oil a gun is to put about 3 drops in the hole that is in the asa and dryfire about 12 times. this get the oil throughout the whole gun. hope i helped. usually leaks are easy fixes.
SCATHED is offline View My Blog!   Reply With Quote
Old February 23rd, 2006, 08:06 PM   #3 (permalink)
 
Join Date: Feb 2006
Posts: 4
Thank you, scathed. I will look for a dry O ring.

Thing is though this started after I took the gun apart. And the gas flow I think is too strong to be a leak. I think its some part that is supposed to keep the shot load trapped before you pull the trigger and launch the ball? Do you get what I mean?
Ryan87 is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old February 23rd, 2006, 08:17 PM   #4 (permalink)
Offical PBF Hater
 
Jester of Paint's Avatar
 
Join Date: Jul 2005
Location: Wisconsin
Posts: 2,748
^^^^pic would be nice

i think u assembled it wrong look at a gun diagram and put it back together
__________________
-Nick

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jester of Paint is offline View My Blog!   Reply With Quote
Old February 23rd, 2006, 10:03 PM   #5 (permalink)
Senior Member
 
Charger's Avatar
 
Join Date: Jan 2003
Location: so cal
Posts: 2,618
is it cocked?
__________________
the best way to fix my paintball gun is with a bfh (big f***ing hammer)


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Charger is offline View My Blog!   Reply With Quote
Old February 24th, 2006, 02:10 AM   #6 (permalink)
 
Join Date: Feb 2006
Posts: 4
It does it either way. Cocked or uncocked.

It shouldnt matter, just something came loose that is supposed to keep the gas shut off, I have no idea what, but thats what it is.
Ryan87 is offline View My Blog!   Reply With Quote
Old February 24th, 2006, 02:45 PM   #7 (permalink)
Elite Member
 
Boss's Avatar
 
Join Date: Nov 2001
Location: Oswego, NY
Posts: 713
You definitely reassembled it wrong. This ok though, many people do it. Get a exploded parts diagram or assembly instructions and try doing it again. Make sure you have all the parts. For more information on it and where you can find the diagrams go to www.beog.org
__________________
Jason Boss

140 rd pods for sale color: gold
$2 a piece plus shipping.
Email or PM me if interested


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Boss is offline View My Blog!   Reply With Quote
Old February 25th, 2006, 08:35 PM   #8 (permalink)
 
Join Date: Feb 2006
Posts: 4
Cool, thanks for the help. I took it apart and put it back together, some little part wasnt seated right or something down near where the gas inlet is. It works fine now.
Ryan87 is offline View My Blog!   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums
Copyright (C) Verticalscope Inc Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc. Search Engine Optimization by vBSEO 3.6.1