G3 Woes - Paintball Forum - Paintball guns and gear forums

Reply

Old June 29th, 2011, 08:43 AM   #1 (permalink)
Registered User
 
Pup1286's Avatar
 
Join Date: Jun 2011
Location: KC, Mo
Posts: 45
G3 Woes

So.. I bought a new G3 (never used, not really NEW). Took it out for the first time this weekend and just wanted to share my unpleasantries

First.. The tank i bought with it was out of hydro, turns out they messed up the O-ring behind the reg whenever they put that back on.. Fail for hydro-testing.

Second.. These mysterious Regulator issues on the G3 started happening (imagine that!). Turns out the Solenoid was gunked up bad inside, possibly the battery was dead (i should've changed it). Might've been triggered due to next issue.

Finally.. So after all this, shot it all day, came home to find out that the manual was wrong After doing research i found out the shim stack diagram was incorrect. This is bad because i made mine match the diagram since i dropped them while i cleaned it after i bought it. I hope there are no long-terms effects from this.. Sounds like i should invest in a spare parts kit!

Other than that, i shot 2 balls into my barrel plug (blamed on me being a nub ) and am riddled with bruises Not bad experience i think Hopefully next time will be better! Certainly shoots better than the Tippy rentals! I'm thinking that in a few months i'm going to up the reg to a CP if this doesn't calm down.
Pup1286 is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old June 29th, 2011, 08:47 AM   #2 (permalink)
WARNING: Anti-Social
 
Badseed_666's Avatar
 
Join Date: Apr 2011
Location: Wisconsin
Posts: 330
Are any of these problems still occurring? Btw, you should ALWAYS invest in a spare parts kit and an up to date manual. I'm not really sure what to do for the issue with the shim stack. Wish I could be more help but I haven't worked on a G3 in forever.
__________________
Disneyland? F*** man, this is better than Disneyland!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Badseed_666 is offline View My Blog!   Reply With Quote
Old June 29th, 2011, 08:56 AM   #3 (permalink)
Registered User
 
Pup1286's Avatar
 
Join Date: Jun 2011
Location: KC, Mo
Posts: 45
They loned me a tank to use for the day. They said they didn't want to fill the one i had since they had to put new thread-locker on it and to wait 48 hours. So i'm not sure about the tank issue.

Once we cleaned out the solenoid the gun seemed to work fine, although we only chrono-ed it once. I shot about 600 balls out of it with no obvious problems (but that isn't saying much, as i am still pretty new). So we'll see on the next trip.

I didn't want to buy the kit straight away since i had already dropped ~300 on everything to get started. But i'll be looking for that next for sure.

Up to date manual? This was the last thing i thought of because everyone always said "DP manuals are the BEST!" For the shim stack i just fixed it. The manual shows ()()()(), but obviously it should be )()()()( I was thinking it made no sense when i did it, but what do i know? They had a lengthy post on pbnation about it.
Pup1286 is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old June 29th, 2011, 09:05 AM   #4 (permalink)
WARNING: Anti-Social
 
Badseed_666's Avatar
 
Join Date: Apr 2011
Location: Wisconsin
Posts: 330
PBnation always has a **** ton of information. And DP manuals are pretty nice but always have an up to date manual for your marker. But it seems like everything has been taken care of so it looks like you're all set! Good luck!
__________________
Disneyland? F*** man, this is better than Disneyland!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Badseed_666 is offline View My Blog!   Reply With Quote
Old June 29th, 2011, 03:38 PM   #5 (permalink)
Registered User
 
Pup1286's Avatar
 
Join Date: Jun 2011
Location: KC, Mo
Posts: 45
Quote:
Originally Posted by huckduck View Post
I actually don't run loctite on my tanks. could be me being ignorant, but the guys i play with don't use it either.
I lurked around a little, and i guess it's no big deal either way. Just a precautionary measure? I don't plan on taking my reg off for about 5 years (and i won't be doing it), so i figure it doesn't hurt.
Pup1286 is offline View My Blog!   Reply With Quote
Old June 30th, 2011, 08:44 AM   #6 (permalink)
WARNING: Anti-Social
 
Badseed_666's Avatar
 
Join Date: Apr 2011
Location: Wisconsin
Posts: 330
Well, it's always good to take precautionary measure to make sure everything works as it should. As for switching out your reg, smart choice. Now yer using yer tabbagas *taps head for emphasis*.
__________________
Disneyland? F*** man, this is better than Disneyland!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Badseed_666 is offline View My Blog!   Reply With Quote
Old July 7th, 2011, 04:33 PM   #7 (permalink)
supernoob
 
QUENCY's Avatar
 
Join Date: Jun 2009
Location: Katy, Texas
Posts: 201
i had some of the same problems, all fixed when i...
1) cleaned up the noid a little (mine wasnt bad)
2) the screw for the output pressure on the reg was tight, so i loosened it and it shot like a dream.
__________________
GREY/BLACKGEO +
QUENCY is offline View My Blog!   Reply With Quote
Old July 8th, 2011, 08:30 AM   #8 (permalink)
Registered User
 
Pup1286's Avatar
 
Join Date: Jun 2011
Location: KC, Mo
Posts: 45
I was waiting for you to chime in quency! I saw that you have the same gun. Must be that the noids were nasty from the factory...

Also, what was wrong with the hpa tank is that the gage was leaking. Someone crossthreaded or tightened it too much (assuming the hydro guys since it had air in it when i bought it). We put some heavy duty tape on it and tightened it pretty good, seems to be holding on good for now! I'll just wait until it breaks before buying a new reg ^^
Pup1286 is offline View My Blog!   Reply With Quote
Old July 8th, 2011, 08:45 AM   #9 (permalink)
Senior Member
 
Riddler236's Avatar
 
Join Date: Jul 2005
Location: Pittsburgh, PA
Posts: 2,317
Those solenoids are super durable and rebuildable... I can only suspect that some of the crappy factory grease got in there.
Riddler236 is offline View My Blog!   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums
Copyright (C) Verticalscope Inc Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc. Search Engine Optimization by vBSEO 3.6.1