Spyder Electra Problem. - Paintball Forum - Paintball guns and gear forums

Reply

Old May 31st, 2011, 02:12 PM   #1 (permalink)
Registered User
 
Join Date: May 2011
Posts: 2
Spyder Electra Problem.

Hey guys, I just started paintballing and I really got into the sport. Now, I just purchased a Spyder Electra and I was so happy when it got here. I was first disappointed with it did not come with a LED display. Turns out they now have the Tadao circuit board other than the LEAP. So when I first shot the paintball gun, it worked and then after 5 shots, it stopped shooting. The cock or whatever it's called did now go forward so the paintball wasn't flying out. What could be the problem? I had a full tank of C02. I called up Spyder and they told me that my battery was the problem. I was using a 9V Duracell battery and they told me to purchase the Spyder 9.6V Rechargeable battery. Now, I was a bit unconvinced when I heard this. Does the .6V really make that big of a difference. I have one currently shipping and will arrive in about 4 days. But if it's not the battery, what could it be? I don't want to return because I would have to pay a 15% restocking fee + shipping and handling.
B3LikeFung is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old May 31st, 2011, 02:22 PM   #2 (permalink)
Authoritah!
 
martix_agent's Avatar
 
Join Date: Nov 2004
Location: Lafayette, Indiana
Posts: 23,645
have you tied lubing it with paintball or air tool oil?
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
martix_agent is offline View My Blog!   Reply With Quote
Old May 31st, 2011, 02:23 PM   #3 (permalink)
Registered User
 
Join Date: May 2011
Posts: 2
Yeah, I've lubed it with paintball oil.
B3LikeFung is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old May 31st, 2011, 04:39 PM   #4 (permalink)
Super Legit
 
Trbo323's Avatar
 
Join Date: Nov 2006
Location: Washington
Posts: 14,001
well if your sear is not tripping then its not a issue with the oil anyway. id throw a different battery in just to try, again, name brand and brand new
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


^^^If you are new, click here^^^


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

^^^ Putting together your tool bag?? Click here! ^^^
Trbo323 is offline View My Blog!   Reply With Quote
Old June 10th, 2011, 06:47 PM   #5 (permalink)
Registered User
 
Join Date: Jun 2011
Posts: 3
Quote:
Originally Posted by B3LikeFung View Post
Hey guys, I just started paintballing and I really got into the sport. Now, I just purchased a Spyder Electra and I was so happy when it got here. I was first disappointed with it did not come with a LED display. Turns out they now have the Tadao circuit board other than the LEAP. So when I first shot the paintball gun, it worked and then after 5 shots, it stopped shooting. The cock or whatever it's called did now go forward so the paintball wasn't flying out. What could be the problem? I had a full tank of C02. I called up Spyder and they told me that my battery was the problem. I was using a 9V Duracell battery and they told me to purchase the Spyder 9.6V Rechargeable battery. Now, I was a bit unconvinced when I heard this. Does the .6V really make that big of a difference. I have one currently shipping and will arrive in about 4 days. But if it's not the battery, what could it be? I don't want to return because I would have to pay a 15% restocking fee + shipping and handling.
yoyoyo, im putting up a psot aobut it too, with a youtube video, of my gun, tell em fi thats ur exact probelm, cause i guess spyders have these probelms .. anyways ima buy a new battery also soon
yurij13 is offline View My Blog!   Reply With Quote
Old June 10th, 2011, 10:26 PM   #6 (permalink)
Super Legit
 
Trbo323's Avatar
 
Join Date: Nov 2006
Location: Washington
Posts: 14,001
please type what you are trying to say. having to decode slang is rather annoying
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


^^^If you are new, click here^^^


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

^^^ Putting together your tool bag?? Click here! ^^^
Trbo323 is offline View My Blog!   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums
Copyright (C) Verticalscope Inc Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc. Search Engine Optimization by vBSEO 3.6.1