broke invert mini's need help - Paintball Forum - Paintball guns and gear forums

Reply

Old February 17th, 2008, 12:02 PM   #1 (permalink)
 
Join Date: Feb 2008
Posts: 2
broke invert mini's need help

I have one brand new mini with 1000 rounds through it, and it will not even air up the marker and when it does it leaks through the barrel... help...

I have also bought 2 other mini's last June and I just bought 2 new Freak sets (cocker thread) and they do not fit the gun.. but they will fit the one that is broke..... it seems like that the body was not milled out enough to get the freak back to slide into the marker. We now have tried other cocker thread barrels and they do not work either. can anyone lead me in the right direction or phone number to someone who can..... I am getting very FRUSTRATED with these markers... even though I do love them and love how they shoot with the stock barrrel (only).....

thanks for any Help......
dirtyoldman is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old February 17th, 2008, 01:10 PM   #2 (permalink)
JH
Senior Member
 
Join Date: Nov 2005
Location: Atlanta
Posts: 2,228
Try a new battery.

Also some old freak backs do not fit the minis. Looks like you are sol on that one.
JH is offline View My Blog!   Reply With Quote
Old February 17th, 2008, 02:00 PM   #3 (permalink)
 
Join Date: Sep 2007
Posts: 41
I've used Freak barrels in the past. They were OK I guess. I've had really good luck with a Dye Ultralite on my Mini.
OKRedline is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old February 17th, 2008, 03:44 PM   #4 (permalink)
 
Join Date: Feb 2008
Posts: 2
we have one marker that works with the freak back and the other 2 markers do not work with the same back....

and yes we put in a number of new batteries
dirtyoldman is offline View My Blog!   Reply With Quote
Old February 17th, 2008, 05:21 PM   #5 (permalink)
 
Join Date: Feb 2006
Posts: 6,346
Try some lube on the bolt o-rings(if it has any, if not try lubing the bolt itself), that always has fixed my bolt leaks.
kenny_1491 is offline View My Blog!   Reply With Quote
Old February 18th, 2008, 09:58 AM   #6 (permalink)
 
Join Date: Jan 2007
Posts: 178
if you are still having issues you can call KEE directly at 1-800-220-3222.
MattyJay88 is offline View My Blog!   Reply With Quote
Old February 18th, 2008, 11:28 AM   #7 (permalink)
JH
Senior Member
 
Join Date: Nov 2005
Location: Atlanta
Posts: 2,228
Try resetting the poppit by moving the velocity adjuster all the way in and then back out. Also reset the ASA/Reg the same way.
JH is offline View My Blog!   Reply With Quote
Old February 18th, 2008, 11:36 AM   #8 (permalink)
 
Join Date: Jan 2007
Posts: 178
Quote:
Originally Posted by JH View Post
Try resetting the poppit by moving the velocity adjuster all the way in and then back out. Also reset the ASA/Reg the same way.
to reset the noid you need to pull the trigger with eyes off and click it about 50-100 times. the asa shouldn't be affected unless his pressure is way off.
MattyJay88 is offline View My Blog!   Reply With Quote
Old February 18th, 2008, 11:43 AM   #9 (permalink)
JH
Senior Member
 
Join Date: Nov 2005
Location: Atlanta
Posts: 2,228
If you back out the asa-reg too far it will not air up.
JH is offline View My Blog!   Reply With Quote
Old February 28th, 2008, 10:41 AM   #10 (permalink)
Shnazberries!
 
cspaintball's Avatar
 
Join Date: Aug 2007
Location: iowa
Posts: 385
this is why i didnt invest money in a new technology like this.......
i think empire news to redo the bolt design
__________________
These Shnazberries taste like Shnazberries!



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cspaintball is offline View My Blog!   Reply With Quote
Old February 28th, 2008, 12:20 PM   #11 (permalink)
JH
Senior Member
 
Join Date: Nov 2005
Location: Atlanta
Posts: 2,228
Quote:
Originally Posted by cspaintball View Post
this is why i didnt invest money in a new technology like this.......
i think empire news to redo the bolt design
What are you talking about? User error is more than likely what caused this. You are totally off base and it is people like you that make people say bad things about Minis.
JH is offline View My Blog!   Reply With Quote
Old March 3rd, 2008, 10:16 PM   #12 (permalink)
Senior Member
 
lovetocheat69's Avatar
 
Join Date: Dec 2003
Location: Wisconsin
Posts: 2,061
You have to sand the thread on the older freaks to get them to fit. Check on PBnation, should be a writeup there.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
lovetocheat69 is offline View My Blog!   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums
Copyright (C) Verticalscope Inc Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc. Search Engine Optimization by vBSEO 3.6.1