I need help with my invert mini! - Paintball Forum - Paintball guns and gear forums

Reply

Old November 17th, 2008, 12:49 AM   #1 (permalink)
 
Join Date: Nov 2008
Posts: 2
I need help with my invert mini!

hey everyone, so I just got an invert mini, and i bought a pure energy 50/4500 but i can't seem to get things going. whenever i try to put it in, it just shoots air out of the bottom line regulator... no doubt because the tank is putting out more than it can handle. What do i need to do in order to adjust the output pressure on the tank?
kingdedede is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old November 17th, 2008, 12:53 AM   #2 (permalink)
Authoritah!
 
martix_agent's Avatar
 
Join Date: Nov 2004
Location: Lafayette, Indiana
Posts: 23,645
it's not the tank, it's he inline regulator.

I'm not sure if the minis regulator vents out at pressure that is too high. If it does, you need to turnthe inline regulator down.

If that doesn't solve it, it could either be the regulators o-rings or the solenoid that is busted.

Again, I dont' know much about the mini and how they put everything intothe grips and whatnot.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
martix_agent is offline View My Blog!   Reply With Quote
Old November 17th, 2008, 12:43 PM   #3 (permalink)
Established member
 
tlmiller's Avatar
 
Join Date: Oct 2004
Location: AZ, USA
Posts: 9,221
If it's not going on all the way that will also cause it. The purge holes are often so that the pin will depress the tank pin before the tanks oring passes the purge holes.
__________________
Yes, I have long since accepted that I have issues, with that said, here's:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tlmiller is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old December 24th, 2008, 12:27 AM   #4 (permalink)
 
Join Date: Dec 2008
Posts: 7
The instructions recommend an impute pressure (from the tank) at somewhere between 350-450psi. Perhaps your high pressure tank is too much?
Bolvangar is offline View My Blog!   Reply With Quote
Old December 24th, 2008, 09:01 AM   #5 (permalink)
Boom Chika Wha Wha!!!
 
TBDragonMan's Avatar
 
Join Date: Jul 2006
Location: Thunder Bay, Ontario, Canada
Posts: 245
No its not that. I use a crossfire 68/4500 high pressure and have never had a problem. The on;y issue I have is with no on/off on the regulator putting on and taking off the tank is a hassle and hard on tank orings.
__________________
If life is getting hard on you...kick him in the nads a steal his wallet.
TBDragonMan is offline View My Blog!   Reply With Quote
Old December 24th, 2008, 09:10 AM   #6 (permalink)
Super Legit
 
Trbo323's Avatar
 
Join Date: Nov 2006
Location: Washington
Posts: 14,001
in those instructions they recomend a LP input but they also say it can work with a HP input
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


^^^If you are new, click here^^^


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

^^^ Putting together your tool bag?? Click here! ^^^
Trbo323 is offline View My Blog!   Reply With Quote
Old December 25th, 2008, 11:17 PM   #7 (permalink)
 
Join Date: Dec 2008
Posts: 7
^^^ Well the instructions don't say a HP tank is ok...

So the only problem with using a HP tank is that it's harder to put on and take off and is bad for the o-rings? Is there anyway you can add an on/off?
Bolvangar is offline View My Blog!   Reply With Quote
Old December 25th, 2008, 11:25 PM   #8 (permalink)
Registered BAMF
 
NorCalBaller's Avatar
 
Join Date: Dec 2007
Location: NorCal
Posts: 221
i know this may sound stupid, but this sounds like what your problem is, make sure your tank o-ring is still there and hasn't broken, that would explain it..
__________________
Quote:
it doesn't seem like some of these guys have even played before.....

the only barrels they've played with are in their pants


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Upgrades - Ndz on/off asa, Virtue destrokyr .45 grips, Kila Drive Board V2.2, Kila Magnetic Detents/Eye Covers, Vaporworks Laser Eyes, CP reg, DBN 15 Degree ASA adapter, CP Trigger, Crammer 2.0(Ram housing and shaft - only 40 made), Ebay Valve, AKA SCM III Low Pressure Regulator, BP Bullet Nose Adjuster cap for SCM III, Shocktech Superfly Bolt Pin, Deadlywind Carbun Fibur Barrel w/ Deadlywind Insert Kit, Low-rise clamping feedneck from ebay (no brand name).

Setup - Red Promaster, Vlocity Jr w/Gangstar chip, PMI 45ci/4500psi w/NXe black cover
NorCalBaller is offline View My Blog!   Reply With Quote
Old January 2nd, 2009, 04:07 PM   #9 (permalink)
The player makes the gun
 
xerox_epoch's Avatar
 
Join Date: Aug 2008
Location: At Your Mom's House
Posts: 108
Easy

This happened to me too listen you have to replace your tank o-ring then set the inline reg to 200psi. I use a high pressure tank and it works just fine. ^^^^^^^^ they say it's hard on o-rings, it is'nt all it does is it makes it harder to screw out of the reg just put a drop of tri-flow or oil in the reg NOT THE FILL NIPPLE. put the oil or Tri-flow on the part that screws into the reg. That solves the screw in problem. But just turn down the reg and replace the tank o-ring. Try that.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
If someone ever told you that you suck, and then you went and got better put this in your sig

--------------------------------------------------------------------------------------------------------------

Pink Lady Ego 09
50/4500 Pure Energy Tank
Empire Prophecy
xerox_epoch is offline View My Blog!   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums
Copyright (C) Verticalscope Inc Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc. Search Engine Optimization by vBSEO 3.6.1