Need help with my electra dx - Paintball Forum - Paintball guns and gear forums

Reply

Old May 28th, 2005, 01:38 PM   #1 (permalink)
 
Join Date: May 2005
Posts: 11
Need help with my electra dx

Well the hammer that hits the pin to make it drop isn't hittin the pin all the way so the pin doesn't move causing the bolt not to go foward. The problem is that my gun won't fire cause of this lil problem. any ideas to fixing it?
timt0874 is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old May 28th, 2005, 10:38 PM   #2 (permalink)
Screaming Koala
 
Torch's Avatar
 
Join Date: Nov 2004
Location: Bentleyville, PA
Posts: 4,685
Blog Entries: 1
I hadn't figured it was electric. My mistake.

That hammer is called a solenoid, and it's hitting the sear and should be, but isn't, releasing the hammer.

There's a few things that can cause this. I'd say the most common is not enough power. If you have the rechargable in there, give it a good charging. If you're using throw-away nine volts, change it out for a new one.

Another reason is too much spring tension from the drive spring. I'm going to guess that you haven't changed it from the stock spring, so this probably won't be the problem. Still though, you can try backing off on the velocity a little (turn it ******ds) to see if that helps. If you have changed the spring though, try a lighter one.
__________________
"RD&D - Research, Development, and Design. - If its not broken, fix it anyway."
T.O.G. #131 - P.O.G. #16 - C.O.G. #145
Rate the:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Torch is offline View My Blog!   Reply With Quote
Old May 29th, 2005, 03:47 PM   #3 (permalink)
 
Join Date: May 2005
Posts: 11
thank you torch, it was the battery
timt0874 is offline View My Blog!   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums
Copyright (C) Verticalscope Inc Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc. Search Engine Optimization by vBSEO 3.6.1