rodeo expansion chamber leak - Paintball Forum - Paintball guns and gear forums
Paintball Forum

Reply

Thread Tools  

Old October 30th, 2016, 01:25 PM   #1 (permalink)
Registered User
 
Join Date: Oct 2016
Posts: 3
rodeo expansion chamber leak

can anyone tell me how to fix a leak on the set screw of the expansion chamber on my spyder rodeo replaced o rings but there is no way to take the expansion chamber apart any help would be greatly appreciated
jr0308 is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old October 30th, 2016, 01:46 PM   #2 (permalink)
Authoritah!
 
martix_agent's Avatar
 
Join Date: Nov 2004
Location: Lafayette, Indiana
Posts: 23,645
It's been a long time since i've seen a rodeo. Is it leaking from the allen key in the center of it? If so, you're going to need to rebuild it.

here's what somebody had to say about this exact issue
http://www.spyder.tv/forums/showthread.php?t=21681
Quote:
Remove bottom hose from ASA

Two small brass screws using the RIGHT size allen key ( I find these to be very fragile) remove all the way

Pull reg from block being careful not to damage O-ring pull straight out.

On the stainless part ( not anodized ) using an adjustable wrench and a table cloth ( so you dont scratch it) twist the top portion of your regulator off.

looking in from the threaded end, you will see a brass disc. Very gently tap the knurled end to basically shake this brass disc out. Its T shaped and also fragile. Remove and carefully inspect the O-ring. Use the right one and replace, should fix your problem, if not post back for a further break down.
It's going to be similar to this
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by martix_agent; October 30th, 2016 at 01:51 PM..
martix_agent is offline View My Blog!   Reply With Quote
Old October 30th, 2016, 01:49 PM   #3 (permalink)
Registered User
 
Join Date: Oct 2016
Posts: 3
It is the set screw just above my finger

Last edited by Trbo323; January 11th, 2017 at 02:21 PM..
jr0308 is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old October 30th, 2016, 01:52 PM   #4 (permalink)
Authoritah!
 
martix_agent's Avatar
 
Join Date: Nov 2004
Location: Lafayette, Indiana
Posts: 23,645
Wow, nice photo!

I jut edited my post with relevant information that should help you out.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
martix_agent is offline View My Blog!   Reply With Quote
Old November 1st, 2016, 10:07 AM   #5 (permalink)
Super Legit
 
Trbo323's Avatar
 
Join Date: Nov 2006
Location: Washington
Posts: 13,998
Martix it's a x chamber not a regulator

Step 1, take screw out
Step 2 wrap screw with some Teflon tape
Step 3 profit!
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


^^^If you are new, click here^^^


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

^^^ Putting together your tool bag?? Click here! ^^^
Trbo323 is offline View My Blog!   Reply With Quote
Old November 1st, 2016, 04:35 PM   #6 (permalink)
Authoritah!
 
martix_agent's Avatar
 
Join Date: Nov 2004
Location: Lafayette, Indiana
Posts: 23,645
What?
Why is that screw there, then?
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
martix_agent is offline View My Blog!   Reply With Quote
Old November 1st, 2016, 05:52 PM   #7 (permalink)
Super Legit
 
Trbo323's Avatar
 
Join Date: Nov 2006
Location: Washington
Posts: 13,998
Good question, buy seeing as the green zone on the guage is right at 750psi there is no need for a reg
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


^^^If you are new, click here^^^


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

^^^ Putting together your tool bag?? Click here! ^^^
Trbo323 is offline View My Blog!   Reply With Quote
Old January 11th, 2017, 07:40 AM   #8 (permalink)
Registered User
 
Join Date: Jan 2017
Posts: 10
Quote:
Originally Posted by jr0308 View Post
can anyone tell me how to fix a leak on the set screw of the expansion chamber on my spyder rodeo replaced o rings but there is no way to take the expansion chamber apart any help would be greatly appreciated

I have the exact same problem. Its actually the reason I made an acct on this forum. I sent my Rodeo to a local shop to be repaired. Ill let you know the outcome. Good luck with your fix.
BayBoyJoe is offline View My Blog!   Reply With Quote
Old January 13th, 2017, 07:24 AM   #9 (permalink)
Registered User
 
Join Date: Jan 2017
Posts: 10
My Rodeo is back up and running. Just had to replace the o-rings in the expansion chamber
BayBoyJoe is offline View My Blog!   Reply With Quote
Old January 13th, 2017, 07:27 AM   #10 (permalink)
Authoritah!
 
martix_agent's Avatar
 
Join Date: Nov 2004
Location: Lafayette, Indiana
Posts: 23,645
Quote:
Originally Posted by BayBoyJoe View Post
My Rodeo is back up and running. Just had to replace the o-rings in the expansion chamber
Cool! This is pretty much what I meant when I said "rebuild it"
martix_agent is offline View My Blog!   Reply With Quote
Old June 26th, 2019, 06:38 PM   #11 (permalink)
Registered User
 
Join Date: Jun 2019
Posts: 2
I have the same issue and I replaced both o-rings in the x chamber and now its leaking from the barrel. I replaced those 2 o-rings and it's still leaking. I have the same issue in my rodeo and special edition. I.ust be doing something wrong. Not sure if its cause I switched from co2 to pressurized air.
Cnk6869 is offline View My Blog!   Reply With Quote
Old June 29th, 2019, 01:19 AM   #12 (permalink)
Super Moderator
 
huckduck's Avatar
 
Join Date: Nov 2010
Location: Canada
Posts: 3,796
cup seal. either that or you forgot to cock it
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
huckduck is offline View My Blog!   Reply With Quote
Old June 30th, 2019, 10:44 AM   #13 (permalink)
Registered User
 
Join Date: Jun 2019
Posts: 2
I replaced the cup seal. It was holding air for 15 min and shot about 50 rounds and set it down and I heard it start hissing. I replaced the o-rings in the expansion chamber as it was leaking. The o-rings in there were squishy like a gummy bear so I put new o-rings but they were normal firmness, wondering if that's the issue. Dont know a lot about the o-rings in the x chamber.
Cnk6869 is offline View My Blog!   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums
Copyright (C) Verticalscope Inc Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc. Search Engine Optimization by vBSEO 3.6.1