Etek plus virtue - Paintball Forum - Paintball guns and gear forums

Reply

Old July 14th, 2007, 02:01 PM   #1 (permalink)
 
Join Date: Jun 2007
Posts: 54
Etek plus virtue

Hey guys just picked up my etek and through a virtue board in it, and have a little problem it seems like when i ramp or shoot fast my bolt isnt recycling all the way anyone know what that could be, possibly the dwell. and if not just for the hell of it i would like to what other people have there dwell set at, thanks in advance.
Sp_ION_07 is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old July 14th, 2007, 08:43 PM   #2 (permalink)
Senior Member
 
burningcow422's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 6,191
i'm not an ego person (and i've never owned a poppet valved gun now that i think about it..) but try lubing your rammer or whatever you call it.
__________________
it is i.
burningcow422 is offline View My Blog!   Reply With Quote
Old July 14th, 2007, 08:54 PM   #3 (permalink)
Image Hosting by Picoodle.com
 
Join Date: Oct 2002
Posts: 5,080
Replace the battery before messing with anything and see if that fixes it.

It's the either the dwell or there's a flow problem meaning the LPR and/or HPR and/or tank regulator is dirty or not set right. Check the manual and reset the LPR and dwell back to stock, that will most likely solve the problem, if not check the HPR and test the tank on another gun to see if you have the same problem.

Quote:
Originally Posted by burningcow422 View Post
i'm not an ego person (and i've never owned a poppet valved gun now that i think about it..) but try lubing your rammer or whatever you call it.
That's a possible cause but rather unlikely, it sounds like his Ego is pretty new and Egos don't need much maintenance to work fine anyways. Might as well try though anyways, clean off the ram and re-oil it.
DarkTamer is offline View My Blog!   Reply With Quote
Sponsored Links
Advertisement
 
Old July 15th, 2007, 12:50 AM   #4 (permalink)
 
Join Date: Jun 2007
Posts: 54
thanks guys, im sure it will help.
Sp_ION_07 is offline View My Blog!   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


VerticalSports
Baseball Forum Golf Forum Boxing Forum Snowmobile Forum
Basketball Forum Soccer Forum MMA Forum PWC Forum
Football Forum Cricket Forum Wrestling Forum ATV Forum
Hockey Forum Volleyball Forum Paintball Forum Snowboarding Forum
Tennis Forum Rugby Forums Lacrosse Forum Skiing Forums
Copyright (C) Verticalscope Inc Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc. Search Engine Optimization by vBSEO 3.6.1