Paintball Guns and Gear forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I know that there are thousands of questions about troubleshooting them. I do what they tell me to do. I turn the adjustment screw in and fire 4 or 5 times until the trigger pull is hard. So I know that its right. So i slowly start turning it out. But i cant get it to "pop". That piston doesnt push out some times. Could there be a problem with that? Maybe I need to lube it perhapse. I just dont know, if we had a shop in the area I would bring it to them but we dont. I have spent weeks looking on line trying to figure it out.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
i bought the response trigger brand new from tippmann. First problem i thought it might be was my stock I put on. I read if its loose CO2 could escape, So I got some thicker gaskets for it and installed them. Still no luck. I took apart my gun yesterday thinking maybe there was a o-ring missing. But all the o rings were good. I dont know why the piston would push all the way out when i would turn my adjustment screw all the way in. But as a turn it out a few times the piston does not push out anymore.
 

·
Banned
Joined
·
14,001 Posts
im wondering if you just dont have a high enough input pressure to the RT, id oil the pison as best you can and see if that helps any, i think whats happening is if you turn the adjustment screw all the way in that is increasing the pressure to the RT and causes the piston to pop forward, but as you decrease the pressure it does not have enough to come forward again or something is binding

if its new you may want to contact Tippmann and see what they say, if there is something wrong from the factory they should replace it
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5 (Edited)
i was thinking about trying to lube it with white lithum. It seems to me that it might be a little dry and sticky, perhapse causing it to stop when i decrease the pressure. Thanks for your input im going to have to try that.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
got it working. I lube the RT piston threw my tank on took one shot tank ran out. Got a nine ounces filled up tried it and it works. Now i really cant wait to play in a couple weeks.
 
1 - 7 of 7 Posts
Top