Paintball Guns and Gear forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello all. I have been semi into p-ball for about two yrs now. last yr i bought an A5 and did the clicky pen mod and used it till winter.
The other day I purchased a GTA X chamber and RT off of ebay. While waiting
for them to arrive, I polished the internals (I just used wadding polish and rubbed it down real good by hand, then cleaned and oiled it). I installed the X chamber per instructions, making sure to oil the o0ring. Two days later (today) I installed the RT, folowing instuctions again. I always make sure the o-rings are on right, and properly oiled. I put it all back together, gas it up and it's leaking.
It sounds/feels like it is somewhere near the x chamber, but even after firing twenty some times it still leaks. Anyone have suggestions/solutions?? Help!!!!
 

·
Registered
Joined
·
201 Posts
were there any places you were supposed to loctite it or use teflon tape? that's my guess..you have a spot that needs either one of those
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
In the instructions, the only places loctite was used is the elbow fitting onto the tank adapter, and the fitting connected to the x chamber.
I used the supplied loctite in those places. All the other connections
are o-rings.

Also, the leak is bad enough that i can take the tank off, and blow into the tank adapter (as if blowing up a ballon) and it will leak without much effort.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Ok - just to let ya'll know - i got the leak fixed.
I had the o-ring and the flat washer in the power tube switched.
Funny thing is, it worked like that with no leaks for a year!!
 
1 - 7 of 7 Posts
Top