Paintball Guns and Gear forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Guys I need some help with my tippmann.

I took it apart to clean it because the previous owner did not take care of it (it worked good before that) and now after I cock it manually and pull the trigger it won't recock itself some time if i hold the trigger it's like an automatic and chops the hell out of balls. It like the sear isn't catching or the bolt doesn't come back far enough. HELP :(
 

·
Registered
Joined
·
4,186 Posts
try pushing the sear in more mine slipped off the sear pin some times uhhhhhhh the sear mite be worn down depending on hoiw old it is to where it isnt cathing

just thought of this, check the sear spring it mite be so worn that there isnt enough tension 2 move the sear back

hope this helkps and welcome 2 the forums!
 

·
Screaming Koala
Joined
·
4,685 Posts
For the not recocking itself part, look and make sure the detent isn't in backwards. If it is it'll catch the front bolt and will stop the gun from cycling.

As for the full-auto paint blender problem, look over the sear and the rear bolt. Make sure they're both square and not rounded off.
 

·
Registered
Joined
·
36 Posts
hey if it is your sear spring try the ruber band mod in the mod secton that works pritty good exept u might breack a ballevryonce in a while but with nething u will brak balls one in a while
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
rear oring was bad, don't know if i had the ball latch backwards or not i do remember but i will now look at it everytime i take it apart...i put about 100 shots through it seems to be ok now :D

thanks guys wave:
 
1 - 6 of 6 Posts
Top