Paintball Guns and Gear forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Ok, so heres the deal. I bought a used DM8 off ebay and it just arrived today. When I screwed in my airtank, put my hopper on and loaded in some balls to go out and test it, and when I turned it on the flashing green light appeared. Which means that the eyes are malfunctioning. So I unloaded my hopper and degassed the DM8 and proceded to read the manual which said that there was a problem with the eyes. I took out the ball detent/plastic thing (I cant recall the name) cleaned it, and then cleaned the eyes. I then opened the grip and put in a new nine volt battery and tried it again, this time both with the eyes on and off. Both times I tried to fire it, nothing happened, not even the sound of a dry fire. Just some clicking noise's from my pulling of the trigger. I removed my hopper and dry fired it with no paintball in the breech. The bolt did not move forward at all. I then turned the LPR all the way down and then set it to the factory preset and still it didnt fire.

I have no lube or oil with me so I have not done any matinince on it. I also do not know the last time it was cleaned or lubed scince I bought it used. Any help will be appreciated.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #3
Yay, I did something right! Would any kind of lube work, or is Dow33 the best working kind? But what do you mean by "Cleaning lubing"? Is that lubing the parts and then wiping them down to a very small amount of lube?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
Allright thanks. Do you think this is the overall problem, or do you think there could be more problems?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
Ok, I'll get some lube tomorrow and then try that and if that doesnt work, then my ass is off to the pro-shop.
 
1 - 7 of 7 Posts
Top