Paintball Guns and Gear forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
i just bought a e-grip today installed the battery and installed the grip on the gun, turned it on and fired a couple of rounds and now it wont fire i can feel the silenoid moving but it acts like there is not enought force to move the shear when the trigger is pulled i checked to see if the grip was tightned to much and it was all good. the only thing i an think is the cilenoid is bad. i dont know i need help though
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
so if its the capasitor not giving it enought juice, is that something i could change o r should i just take it back. i mean its brand new. i guess i can check it with a volt meter ill try it and let you know
 

·
Registered
Joined
·
16 Posts
mine did the same thing, try taking off the battery and letting the capacitor discharge for a while. mine has never had the problem since i've let it discharce for a while
 

·
Pump is Better
Joined
·
3,424 Posts
By the battery thing you mean taking it off for a while and letting it sit?

If that is what you did, i'm entirly sure what causes it but I think it is because your capasitor (which is designed to hold an electrical charge and then release it and charge back up again) wasn't broken in yet. It just wasn't charging back up right, so you needed to let it drain out and than it got the right charge.

I may not be completly right so someone can correct me if they know more.
 

·
Registered
Joined
·
16 Posts
You are probably right but i figured it out by accident kind of, i had taken the battery out because i was going to return it. but something made me put the battery back in and try it, and it worked.
 

·
Registered
Joined
·
16 Posts
also remember to make sure that the battery wires are not getting pinched because it will stop working, and you will have to put a new battery connecter on it. (stupid mistake i did)
 
1 - 10 of 10 Posts
Top