Paintball Guns and Gear forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hey everyone, so I just got an invert mini, and i bought a pure energy 50/4500 but i can't seem to get things going. whenever i try to put it in, it just shoots air out of the bottom line regulator... no doubt because the tank is putting out more than it can handle. What do i need to do in order to adjust the output pressure on the tank?
 

·
Administrator
Joined
·
23,657 Posts
it's not the tank, it's he inline regulator.

I'm not sure if the minis regulator vents out at pressure that is too high. If it does, you need to turnthe inline regulator down.

If that doesn't solve it, it could either be the regulators o-rings or the solenoid that is busted.

Again, I dont' know much about the mini and how they put everything intothe grips and whatnot.
 

·
Registered
Joined
·
7 Posts
The instructions recommend an impute pressure (from the tank) at somewhere between 350-450psi. Perhaps your high pressure tank is too much?
 

·
Boom Chika Wha Wha!!!
Joined
·
245 Posts
No its not that. I use a crossfire 68/4500 high pressure and have never had a problem. The on;y issue I have is with no on/off on the regulator putting on and taking off the tank is a hassle and hard on tank orings.
 

·
Registered
Joined
·
7 Posts
^^^ Well the instructions don't say a HP tank is ok...

So the only problem with using a HP tank is that it's harder to put on and take off and is bad for the o-rings? Is there anyway you can add an on/off?
 

·
Registered BAMF
Joined
·
221 Posts
i know this may sound stupid, but this sounds like what your problem is, make sure your tank o-ring is still there and hasn't broken, that would explain it..
 

·
The player makes the gun
Joined
·
108 Posts
Easy

This happened to me too listen you have to replace your tank o-ring then set the inline reg to 200psi. I use a high pressure tank and it works just fine. ^^^^^^^^ they say it's hard on o-rings, it is'nt all it does is it makes it harder to screw out of the reg just put a drop of tri-flow or oil in the reg NOT THE FILL NIPPLE. put the oil or Tri-flow on the part that screws into the reg. That solves the screw in problem. But just turn down the reg and replace the tank o-ring. Try that.thumup:
 
1 - 9 of 9 Posts
Top