Paintball Guns and Gear forums banner

1 - 17 of 17 Posts

·
Your Worst Nightmare
Joined
·
5,270 Posts
Discussion Starter #1 (Edited)
I have a '93 grand am SE, has about 40,000 miles on it, and the other week, it decided to throw a **** fit and die on me. Now, i fixed it the first time, i replaced the fuel filter, but then sure enough, a day or two later, something else went on it. I narrowed it down to the fuel pump or a clogged fuel line. The fuel pump was working, but fuel wasn’t getting through the line. So after being stumped, I bit the bullet and took it into a mechanic. Well, yesterday he calls my mom up, and tells her that my car is what you call royally ****ed.

You see, my car has a history of bad electrical problems. Nothing electrical seems to work on it, ever. My battery is drained constantly, and no one can figure out from where or how it’s being drained. Then when they attempted to fix the problem the first and second time, they figured out that there were a boat load of wires in my steering column that were just plain cut, and they weren’t even sure how my car was even running at all at that point. Well, they just figured out that my starter went, again, and basically, 50% or more of my electrical system just shorted out, and now they have to replaced the wiring in my car. Wonderful right?

I finally said enough, I refuse to spend anymore money on this POS. So I went to a car dealer. After getting the run around like the normal car dealer gives you, I managed to get $1000 for my car on a trade in (which is good for something that doesn’t run that I got for free, lol) and I picked up a 2001 Eagles green RAV4 with 30,000 miles on it. Damn thing cost me a **** load, then again, since when are SUV’s cheap right? Especially Toyota’s, for some reason they’re expensive now, lol. So yea, I’m out about 17 grand total, and I have about 5 years to pay it off. Thank god I work for a living! Hopefully this doesn’t cut into paintball ;)

- Brian

Edit


Pics of the new RAV4 (camera phones suck)



 

·
Registered
Joined
·
250 Posts
what engine?... i had a '93 or 94 w/ the quad SOHC... biggest POS car i've ever owned... and that inclues over a 240k mile '85 tercel... it was origianly bought by my wifes granny... it was ALWAYS in the shop even when she owned it... it had a stack of recipts that almost couldn't fit in the glove box... she had the oil done every 3k miles, everything was done by the book... at some point she could no longer drive... so she gave us the car because we needed one at the time...

i drove it for under a year before things REALY started going wrong (the brakes slave cyl's going and neeing new brakes all around i don't consider major lol) anyway driving along the inteior suddenly fogged up to hell... the heater core blew... pulled over and being a few blocks from home got the car home after it had cooled down (never let it overheat)... bypassed the heater core... next day i drove it the water pump died... so i replaced that... and while i was at it did the thermostat... (and for those that don't know the water pump is a *****... have to pull the exhaust manifold off to get to it doh...

anyway i got the pump and stuff done and it still was running hot... so i checked the compression... DAMN... i blew the HG... got the head off and found the head was cracked... all this at 82k miles... ended up selling it to a friend who worked at a junkyard... said it was very normal... the solution is to goto a pushrod v6 which don't seem to have anywhere near the issues... go figure... the packaging makes it even worse... i HATED working on that thing... my arms got so scraped up doh... the worst part is you get all the disadvantes of the 160hp quad4 (dohc16v version) and non of the power 115 hp SUCKS lol

ironicly even my '98 neon which is known for blowing HG's around 80k... i've got just over 100k on it and i've had no problems with the car...

ironicly... the mid engined mr2 i had for about 4 years is a sinch to work on... just most everything requires jack stands...

and for utter simplicity... my 89 volvo 740 wagon is awesome... it tossed a rod under the last owner at 236k miles... so i tossed in a low millage (140k) engine from my old wagon with a crappy body and inteior... easy to work on... and gobs of power with very mild mods.

er ok anyway good upgrade... i'm def a toyota guy... can't beat em :)

mark
 

·
Registered
Joined
·
431 Posts
Hehe, that sucks... this morning some ass on the road hit my parents when they were going to tampa lol.. the car is in the shop right now, i wonder how much this is ganna cost *evil grin*
 

·
startx: command not found
Joined
·
3,991 Posts
my fuel pump on my truck died 2 days ago. it just all of a sudden started acting as if there were no gas. checked and there's no gas going to the carburator. i feel your pain. it better be fixed soon
 

·
Your Worst Nightmare
Joined
·
5,270 Posts
Discussion Starter #15
YES!!! That's exactly what happened, so to speak, lmao. I doubt you've had electrical problems like i've had though, but i hope your wiring didn't short out like mine did. That was a *****. Good luck with that!

- Brian
 

·
startx: command not found
Joined
·
3,991 Posts
i got mine back. It was a bad wire. but the dumbasses took out my fuel pump and ****ed it up when putting it back in or something because now I'm spewing gas every time I turn on my engine :tdown
 
1 - 17 of 17 Posts
Top