Paintball Guns and Gear forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Problems with my Ego 8....before the season even starts.
First got it at xmas. It worked okay, but you could hear it leak in the reg as it had the swivel collar defect.
The collar was replaced by the seller, and | just fired it up tonight.

Minimal power. At first I thought I was in training mode, but I wasn't.
The marker fires but not enough to move the bolt. I thought ~maybe~ the reg was reset when the recall swivel collar was repaired, but as I cranked that up I started to get some lovely hissing and leaking.

So. I cycles, but with very little power, not even enough to move the bolt. Reminds me of low pressure, or running out of gas.

Similar experiences? Ideas? Advice?
 

·
bow chicka
Joined
·
2,640 Posts
Hm, i also have an ego and have never really ran into this problem. Call PE and ask, if nothing else its still under warranty. You hear leaking and hissing? It could be a QEV or leaking noid if you screwed the grip frame screws in too far. Check yoru o-rings to make sure they are good and having a good seal. Use oil on the rammer, not lube (or a grease) cause lube gunks stuff up. Ive heard other peeps talk about a diaphragm but ive never had problems with mine so idk if it could be that also.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #5
Actually had the thing serviced a while ago, something got gouged in the reg during the swivle replacement. New reg, their cost, no problem.
 
1 - 5 of 5 Posts
Top