Paintball Guns and Gear forums banner

1 - 20 of 32 Posts

·
Registered
Joined
·
292 Posts
Discussion Starter #1
I asked this I have a victor 2 and I recently purchased a used frame andwell here the problem


Its been acting really weird! Yesterday I set it up and when I shot it with balls in the chamber, they all broke! Its not a chop but they actually broke!(from pressure?) I tried shooting the gun without any balls in the gun and it made thst spuddering sound but It was going on for a long time and my WHOLE gun got really cold. It did the same thing today. And what made my gun work yesterday was...I oiled it up. But that didnt work today. Today I would try to shoot the gun and it would shoot but it sounded kinda like a spudder whenever it shoot(I wasnt out of air though).

So after that I take my tank off then back on and air leak out the hose...tighten that up. Then later on..I decided I couldnt play because it was acting up but this guy takes my gun up. Shoots it (still making the weird spuddering sounds) but...when he put balls in there it shoot normally(no weird sounds or anything)??? wtf? Earlier today after my whole gun got colder(I guess this is freezing up?) this guy took and o-ring out (from the valve/VA area)and it was broken...I replaced it with a clear one o ring because I didnt have any black ones..and it seemed to work

What could be causing all this? I use the striker that came with my victor 2 with the esp frame btw...
 

·
Registered
Joined
·
882 Posts
Still doing this after you replaced the o-ring? It should work fine now, if not, check all o-rings, tighten all air connections, use sticky tape (plumbers tape) on threads to air connections, just to make sure. If none of that dosent work, then I dont know what to tell you...
 

·
Registered
Joined
·
292 Posts
Discussion Starter #3
Heres the deal...I did replace the o-ring and I was able to play....aight

After the o ring was replaced I palyed a game and it was working great. But from the early incidents I wasted a lot of CO2 and ran out in that game so i called out.(after getting this guy in the army out :p ). I mean...I GUESS the problem is solved and it shouldnt act up but what got me nervous was the fact that it acted up the first day and messing with it and oiling it that day got it to work. Then the next time i play i try to shoot and it does that spuddering thing where it was wasting all my CO2 and the guy opened it up and the o ring was broken. I dont think that o ring was broken from the last game..what do you think could eb causing this? I would obviously shoot my gun to see if it work but im still out of air.

thanks
 

·
Registered
Joined
·
11,482 Posts
go to otterscustoms.com (i beleive is the site) do the polish mod, this will help everything move easier w/ out the oiling and should cut down on bolt sputter.

Ur pballs might be to big for ur barrel causing them to break. That or ur shooting to fast for ur hopper (shouldn't if u have a electric hopper)

On the air leak when u took ur tank off did it come out the ASA as u unscrewed? B/c thats not a leak, that just getting rid of built up pressure. It happens to all of us.

Ur gun is getting cold b/c the co2 can't convert to air fast enough. Only solution here is shot slower.
 

·
Registered
Joined
·
292 Posts
Discussion Starter #5
Well when the gun was acting up I wasnt even shooting fast. Maybe one or two paints balls at a time. And also nah bro it was a loose hose because after we tighten the hose up it was leaking(it was leaking as the tank was on my gun)
 

·
Registered
Joined
·
882 Posts
Also, if you have a electro frame on your victor 2 and set it to auto, the gun will freeze all the time, also, you dont have a expansion chamber on your gun, do you? So, your co2 isnt converting from liquid to air, so your getting little shots of liquid co2 in your gun, destroying your o-rings. Happens to me too, common thing. Get your co2 anti-siphoned or get a expansion chamber.
 

·
Registered
Joined
·
11,482 Posts
^dang i forgot hes got no expansion chamber. Yea, so if u dont even have a chamber then ur co2 is going to have lots of trouble converting to air, leaving u w/ a constantly freezing (and therefor locking up) gun. So ur bolt keeps getting frozen b/c of co2 problems. Tell us if the bolt got cold every time it spuddered, if not then we gotta rethink all this. I still recommend polishing internals.
 

·
Registered
Joined
·
292 Posts
Discussion Starter #8
*UPDATE*

We went out to the woods today and my friend put the e frame on his radeo and it was working perfect! wtf? I tried it on my gun before he put it on his and when I shot the gun it shot the ball and sputtered a little at the same time..then i tried again and it broke the ball(not a chop but it actaully just broke it) and sputtered even more.
 

·
Registered
Joined
·
292 Posts
Discussion Starter #10
Ok cool. The guy who I bought the e-frame from is suppose to be sending me a striker he used when he had a e frame so I will try that out and my friends stiker if it doesnt come tomorrow. Thanks for the suggestion. Im suspecting its either my bolt of striker. Anyone here by chance can show me what e-striker looks like?
 

·
Retired
Joined
·
4,332 Posts
there is no e-striker. its the same no matter what kind of trigger frame you use. your friend may have an "after market" striker, which would mean that it is not produced by kingman. so, you could use your friends striker for a test.
 

·
Registered
Joined
·
292 Posts
Discussion Starter #12
^^ He doesnt have a aftermarket striker though... his rodeo is stock. Damn what could it be if it isnt the striker?


edit: I automatically assumed that the striker for the esp frame was different because kingman took the time to include one with the e frame when you purchase it.
 

·
Retired
Joined
·
4,332 Posts
yeah, but then how do you explain being able to use it (the frame) on your friends rodeo?

and, i was talking about the dude you bought the frame from (who might have the AF striker)....


anyways......i hope you figure it out. i had a similar prob with my piranha, as it turns out, it was the co2 that was messing me up. occasionally little spurts of liquid would get inside and cause burping. of course that may not have been all that was wrong, it was just the last thing i fixed that made it work right.
 

·
Registered
Joined
·
292 Posts
Discussion Starter #14
im starting to think maybe a reg will solve it? If everythign else fails I think a reg can solve it....possibly..
 

·
Registered
Joined
·
292 Posts
Discussion Starter #17
^^ Thats what I want but I was thinking about the bob torpedo because its was like half the price. Is that a good one?
 

·
Retired
Joined
·
4,332 Posts
bob longs are good regs, among the best. the real reason i suggested the palmers is because you are using co2, and palmers is the best for co2. im not sure about the torpedo, you might wanna check out the air equipment forum....a quick search for "torpedo" ought to bring up something..
 

·
Registered
Joined
·
292 Posts
Discussion Starter #19
^^ ok thanks. When my friend gets home im going to try and hookup the reg on his gun to mines and see what happens.
 
1 - 20 of 32 Posts
Top