Paintball Guns and Gear forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
whats up i just joined up here mainly because i have a question about my gun. i have had a victor 2for a while now and never really had any problems until now. the gun does not leak anywhere but for some reason it is not getting any pressure or very little. when there is not a paintball in it the gun sounds like it is at full power or close to it, but sometimes it still has no power even with out a paintball. i do not think it is the seals, because then it would be leaking right? i cleaned it all and greased up all the seals put a fresh tank on it, and it did not even get the paintball out. if i keep cocking and shooting it usually around the 3rd or 4th shot has power, but still not full. if anyone can help me out i would really appreciate it and hopefully i can start playing real games.
thank you
 

·
Premium Member
Joined
·
23,657 Posts
make sure it's put back together correctly. put the striker in, then the spring, then slide the bumper ontot he spring and so on and soforth.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
make sure it's put back together correctly. put the striker in, then the spring, then slide the bumper ontot he spring and so on and soforth.
which spring do you mean? the one under the bolt or the one under the barrell that controls the pressure i believe (where the metal hose hooks to the gun)? the one under the bolt i put in the rubber washer first, then the spring, then the black plastic piece that goes in the spring and then the back piece that holds it all in. the other one when i took it out the spring and everything was connected to the metal piece, and that metal piece has that screw or w/e to control the psi. is the striker the black metal piece that connects to the bolt? and should the rubber washer go on before or after that piece?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
thank you for all your help, but i put it back the same way as the video and it is still having this problem. that is actually why i took it all apart in the first place. i havent used this gun in awhile but last time i used it, it was leaking a little so when i finally decided to use it again i lubed up all the seals, put it back together the right way, and the leaking stopped but now i have this problem. it never had a problem actually shooting, every now and then it would jam or miss one, but never had a problem like this before. it also does not recock but i think that is just because there is not enough pressure going through the gun. could i have a bad valve and when the striker hits all the air is not going into the barrel or not at all?
 

·
Premium Member
Joined
·
23,657 Posts
have you looked downt eh front to see if the valve is all gummed up and to see if the air hoses that go into it are alright? that's the next step. take off the front block and clean all that stuff up as well.

what air source do you use?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
i use co2. i had the front block off and it did not look like it was clogged at all but it was also a little dark to see everything. i took off the hose and checked it also, no problem there i could blow through with out any effort.
 

·
Premium Member
Joined
·
23,657 Posts
hmm maybe your main spring is getting weak for some reason? have you ever left it cocked for long periods of time?

oh, are you trying to use it when it's cold out?
 

·
Registered
Joined
·
6,346 Posts
Try dropping some lube down the asa then dry firing, you never know if you are missing a critical O-ring upon lubrication..
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
i never left it cocked when i wasnt using it. i got the gun from a friend though so i dont know if he ever did, but the spring doesn't look like its worn out or feel like it but i also don't know what it was like brand new so it's a possibility. As far as using it in the cold, it has been like 60-70 degrees here so it cant be that.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #11
Try dropping some lube down the asa then dry firing, you never know if you are missing a critical O-ring upon lubrication..
when i dry fire it the gun sounds fine like it has full power or close to it most of the time, 1 of 5 shots will probably be dead and 1 or 2 will sound weak. whats the asa though?
 

·
Registered
Joined
·
6,346 Posts
Air system Attachment(or something of the sort). It is where you screw your tank in, just drop a couple drops in there and then screw your tank in and dry fire a couple times.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13 (Edited)
Air system Attachment(or something of the sort). It is where you screw your tank in, just drop a couple drops in there and then screw your tank in and dry fire a couple times.
do you mean to put it on the threads right? when i put the fresh tank on, i guess it wasnt lined up right b/c it leaked a little. so i put a few drops on the seal on the co2 tank. it didnt leak but it still did not shoot, later i cleaned off the tank and put it back on and it did not leak but still did not shoot i even shot it a few times with nothing in it too with the lube and with out. :mad:

whenever it is a dry fire i noticed everytime i shot it, i would have different results every shot from sounding like there is no co2 to only half power to full or w/e. also what is the best type of lube to use? could that be a reason?
 

·
Registered
Joined
·
6,346 Posts
NO I mean to drop some down the hole in the ASA where the air goes into.
 

·
Registered
Joined
·
6,346 Posts
Try not to go into peoples threads on there guns and bash them, especially whe nwe are trying to help him fix it.
 

·
Registered
Joined
·
7 Posts
hey buy the way how would i fix my VL lancer when it doesn't cock after i load it.. it will just uncock real slowly
 

·
Registered
Joined
·
9 Posts
Discussion Starter #20
wow i ask for help n this guy comes in to talk crap about the gun then asks for help. thats funny. anyway i finally got it to work. turns out it was so simple. i was using some lube that said it was good for all co2 air compressed guns,turns out they dont mean paintball guns. yesterday i cleaned everything up and lubed it up with tranny fluid instead. works beautiful now. thanx for all ur help guys i really appreciate it. it was so fun shooting it aqain.
 
1 - 20 of 24 Posts
Top