Paintball Guns and Gear forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
can anyone tell me how to fix a leak on the set screw of the expansion chamber on my spyder rodeo replaced o rings but there is no way to take the expansion chamber apart any help would be greatly appreciated
 

·
Administrator
Joined
·
23,645 Posts
It's been a long time since i've seen a rodeo. Is it leaking from the allen key in the center of it? If so, you're going to need to rebuild it.

here's what somebody had to say about this exact issue
http://www.spyder.tv/forums/showthread.php?t=21681
Remove bottom hose from ASA

Two small brass screws using the RIGHT size allen key ( I find these to be very fragile) remove all the way

Pull reg from block being careful not to damage O-ring pull straight out.

On the stainless part ( not anodized ) using an adjustable wrench and a table cloth ( so you dont scratch it) twist the top portion of your regulator off.

looking in from the threaded end, you will see a brass disc. Very gently tap the knurled end to basically shake this brass disc out. Its T shaped and also fragile. Remove and carefully inspect the O-ring. Use the right one and replace, should fix your problem, if not post back for a further break down.
It's going to be similar to this
 

·
Registered
Joined
·
10 Posts
can anyone tell me how to fix a leak on the set screw of the expansion chamber on my spyder rodeo replaced o rings but there is no way to take the expansion chamber apart any help would be greatly appreciated

I have the exact same problem. Its actually the reason I made an acct on this forum. I sent my Rodeo to a local shop to be repaired. Ill let you know the outcome. Good luck with your fix.
 

·
Registered
Joined
·
10 Posts
My Rodeo is back up and running. Just had to replace the o-rings in the expansion chamber
 

·
Registered
Joined
·
2 Posts
I have the same issue and I replaced both o-rings in the x chamber and now its leaking from the barrel. I replaced those 2 o-rings and it's still leaking. I have the same issue in my rodeo and special edition. I.ust be doing something wrong. Not sure if its cause I switched from co2 to pressurized air.
 

·
Registered
Joined
·
2 Posts
I replaced the cup seal. It was holding air for 15 min and shot about 50 rounds and set it down and I heard it start hissing. I replaced the o-rings in the expansion chamber as it was leaking. The o-rings in there were squishy like a gummy bear so I put new o-rings but they were normal firmness, wondering if that's the issue. Dont know a lot about the o-rings in the x chamber.
 
1 - 13 of 13 Posts
Top