Paintball Guns and Gear forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Just to start, I did use search.. I am new to this board, but not to boards... I understand how frustrating it is to answer the same question 100's of time...
OK now my problem
I pull the trigger and release and it keeps firing until i hit the trigger again. I have set the values for semi-auto and even reset it to factory settings. In addition, sometimes when I turn the gun off it will fire. I have replaced all the o-rings I can find.

Second, maybe dumb question. what is the bottom button for. I know that the top turns if off and on, but there is nothing in my users manual about the bottom button.

Thanks for all the help.
08slg
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I took a look at the sear and it looks good. I found a piece of the cleaning rod material in the crook of the sear, and the spring was pretty bent. I flipped the spring and put it all together. Put a fresh battery in it, and it seems to be kinda ok now. I am still sometimes getting 2-3 shots per trigger pull and sometimes it will shoot when attaching the bottle. I can now hear an air leak, so my next step is to completely disassemble the marker and replace all the o-rings again.
 

·
Registered
Joined
·
35 Posts
bottom button turns off/on the eyes. at least on mine. (09 slg basic)
 

·
Banned
Joined
·
14,001 Posts
ya thats right on the bottom from what i remember as well

your issue could be with your tank, if the marker is not getting enough pressure coming into it i could see this happening with the SLG

also lube it up nice and good and see what happens, it may be a case of too much friction in the bolt assembly
 
1 - 7 of 7 Posts
Top