Paintball Guns and Gear forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I recently bought a smartparts ion off a friend and when I went to use it for the first time today it had a leak in the regulator, and I fixed it but the gun wont shoot at all I pull the trigger nothing happens I put a new battery in. And still don't work my friend said he would fix it if it didn't work I was just wandering if it was something simple... P.s. its my first electric gun
 

·
Administrator
Joined
·
23,645 Posts
I could be anything.Have you properly set the regulator?

The board turns on and lights up? Can you hear the solenoid click if you turn the eyes off and pull the trigger without air running to the gun?
This sounds stupid, but is air getting from your tank into the gun?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
I could be anything.Have you properly set the regulator?

The board turns on and lights up? Can you hear the solenoid click if you turn the eyes off and pull the trigger without air running to the gun?
This sounds stupid, but is air getting from your tank into the gun?
I hear the solinoid. There was a leak in the regulator then I took it off and put it back on and it stoked leaking. I'm not sure if the air is going through or not. And the board does turn on
 

·
Banned
Joined
·
14,001 Posts
ions have a pressure gauge on the side, air it up and see if that registers anything. if it does you know air is getting though the regulator, if not you have a reg issue.

I am betting you cranked the regulator closed when you put it back on. so no pressure is getting through, thats also why the leak stopped, no air to leak
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
ions have a pressure gauge on the side, air it up and see if that registers anything. if it does you know air is getting though the regulator, if not you have a reg issue.

I am betting you cranked the regulator closed when you put it back on. so no pressure is getting through, thats also why the leak stopped, no air to leak
I finnaly got it working gave it back to the guy to fix it and he did but I can't shoot it with eyes on its not a big deal just wandering if it was a easy fix and yes I had a paintball in it when I tried to shoot it
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
One of the worst things about the Ion design is having to tear the entire thing apart to do something simple like lube the bolt, so I'd bet your eye wire has just gotten damaged. New eyes and it'll probably be fine.
Ok might get new eyes but idk I'm getting a new gun soon so I'll probably just fix it later
 
1 - 10 of 10 Posts
Top