Paintball Guns and Gear forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
i recently bought a red and black acs piolt for 50$ and im having some issues with it fireing. I took it apart cleaned it up and lubbed put in a new bumber seeing as it was not there and after i cock it back the gun wont fire, when i have the casing off the battery i can see it fireing but its not pushing the bar far enough... not sure whats it called. i can push it with a flat head screw driver and have it release im using a standard 9 volt battery since it did not come with the 9.6 rechargable could that be the issue?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
so i should try and find a place that sells those 9.6 volt batterys huh do you know any sites that would be a good place to purchase one?
 

·
Registered
Joined
·
4 Posts
My Spyder Pilot ACS does the same thing. Have fully charged 9.6 volt battery and when I cock it and then fire it nothing happens except a mild click in the coil set. I can change it to "Auto" & "13 BPS" and it will rip the clicks off, but not enough to fire it the first time.

One probably minor thing is that looking at the capacitor on the end towards the trigger it is slightly bulged out. There is nothing seeping from the bulge and the "X" scoring on the end is not even close to breaking or splitting.

I have a good meter, but I don't know exactly how to check the capacitor.

I have made a quick video of exactly what is going on and maybe someone can nail this problem for me:

Spyder Pilot ACS Firing Problem - Video Dailymotion

Thanks ahead of time for any help that you can offer!!
 
1 - 4 of 4 Posts
Top