Paintball Guns and Gear forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I just picked up a spyder shutter cheap the other day so my ol lady can play with us a little bit and its acting kinda goofy... one thing being that its horribly inacurate! The balls go curving a zipping all over the place... the second is that its not recocking right... Ive put new springs in it and it had new o rings in it before I bought it. It wants to do that studder thing like when they are low on air... where the bolt will kind of bounce back and forth a few times then youll end up having to recock it manually... seems to do it kind of irregularly too.. works pretty good for a few rounds then gets stupid for a few. the only thing I can find out of place inside the gun is in the lower tube theres that rubber doughnut that the spring runs through... thats missing but everything else appears to be in order... Any ideas or help on either issue are GREATLY appreciated! Thanks, nic
 

·
Paintball?
Joined
·
7,646 Posts
1. Check to make sure your barrel is clean fo the accuracy problem

2. You kinda need that rubber doughnut, it saves your marker some quite a bit of damage and helps it last longer. This could also be the sputtering problem. Check to make sure that the rubber doughnut is not infront of the striker
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
The doughnuts not there I just checked and ya the barrel is good and clean. I actually e ven switch the barrel off a different gun to try it and it helped a lil but mainly because it was longer. It was still very inconsistant.

Where can I get one of the little rubber doughnuts to put back in the gun?
 

·
Administrator
Joined
·
14,012 Posts
longer barrel does nothing for accuracy, most likely the inner diameter is smaller and thats why it is better

also paintballs are just not that accurate, they are a liquid filled sphere rolling though the air, good paint will help a lot though, go find some decent stuff from a paintball shop, do not shop for paint at a store that is not paintball specific, they are all sub-par brands that have been sitting for months

if you want a good barrel check out the J&J ceramic, they are $30 and IMO some of the best barrels on the market
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
The accuracy thing isnt the balls Im using... Ive got a big target board that I shoot at and I was shooting the same balls with the same co2 on the same day just out of a couple different guns and the shutter was way off compared to the the other guns. It helped a little to turn the gun down but it was marginal.

And I actually ordered a 16" J&J last week so it should be in soon! Also got a 12" Empire Twister on the way. Picked it up used for 10 bucks lol.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
Rite on... Didnt know if maybe it could be the bolt or something like that... Thought Id check and see...


So do you yall think that putting that striker buffer back in it will help with the sputtering problem? Would changing the valve spring affect it?
 

·
Administrator
Joined
·
14,012 Posts
o that will help it, AZN is much more of an expert on the spyders than i am but the sputtering problem and accuracy are two different issues, the valve spring shouldnt be an issue, put the buffer back in and see if that fixes it
 

·
Registered
Joined
·
82 Posts
Check to see if ur shear is worn down, the gun can go off by itself with the force the hammer coming forward and pushing the shear down by itself. U can always check to see if the valve stem is sticking.
 

·
KRAKEN! KRAKEN! KRAKEN!!!
Joined
·
1,298 Posts
It's called a sear. :)
 

·
Registered
Joined
·
16 Posts
Discussion Starter #11 (Edited)
Check to see if ur shear is worn down, the gun can go off by itself with the force the hammer coming forward and pushing the shear down by itself. U can always check to see if the valve stem is sticking.
Were talking about the trigger mechanism right? Sorry Im not real up on all the names of the parts yet. That makes alot of sence.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #13
Yea I gotcha, I know exactly what your talkin about just didnt know the name of it lol.

Ive found a couple of hammer bumpers on ebay but Im not sure which one I need... I know that the buffer out of a buddies old spyder two wont fit the shutter, so I hate to order the wrong one.
 

·
Registered
Joined
·
82 Posts
Im thinking its that small ones? not 100% sure
 

·
Registered
Joined
·
16 Posts
Discussion Starter #15
I know that the shutter uses a smaller diameter bumper then the old spyder two's. Do the newer spyders use the same bumper as the shutter?
 

·
Registered
Joined
·
82 Posts
I believe so then, cause my imagine parts fits my VS2
 

·
Registered
Joined
·
16 Posts
Discussion Starter #17 (Edited)
The sear is fine, looks new, so i doubt that is the problem. I did find a bad o ring on the valve and I also noticed when I took the gun apart this time that the little brass "valve screw" was turned in all the way. I turned it out a little and it was working better after replacing the bad o ring. Now the main problem seems to be its not recocking. Its still sputtering a little but not as bad, Ill probably get another o ring kit and rebuild the whole gun again. I dont know if its going to help or not but Im getting a delrin bolt. I figured that lightening up the bolt and hammer assembly cant hurt things.

Also something that I think is kind of weird is when I first put a tank on the gun it wont work immediatly, Ill have to run the gun for a little bit and its like once the gun gets cold itll work pretty good. Then after say maybe 30 shots it stops recocking again and turns into a single shot gun lol.

So what is everyones ideas given the new information?
 

·
Paintball?
Joined
·
7,646 Posts
That brass screw keeps your valve in place correctly, I'd screw it back in a bit more and snug it down

Sounds like you're not getting good flow
Try screwing your tank in more
 

·
Registered
Joined
·
16 Posts
Discussion Starter #19
Ok Ill make sure the screw is in all the way. The tank was screwed in all the way, that Im sure of.

I have a hammer bumper ordered but its not here yet, I speculate that is alot of the problem. Ive been poking around the forum and cant seem to come up with any other reason why it wouldnt be working right. Everything looks like its in good shape.
 
1 - 19 of 19 Posts
Top