Paintball Guns and Gear forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Ok I just bought a brand new tippmann A5 gun about 3 weeks ago. So far is has worked fine since i got it. couple days ago i went to play a game and all of a sudden it started acting funny. The I will pull the trigger on semi auto and let off with full co2 tank on it and then it will start firing like crazy and will not stop until i hold the cocking lever back then it stops. I made sure my egrip was working fine by taking the co2 off and then listen to it click and it responds just fine. and also works on egrip safe auto setting.

So it has to be in my gun somehwere i am assuming. i put a co2 tank on that had about 30 shots left on it until it was empty and it seemed to shoot fine to. Its wierd to me. Is there something that is acting up because of high pressure on my gun until is gets to be very low pressure then is starts working normal again. Also when it goes off on a rampage with a full co2 tank on you can feel co2 air around the trigger and line that goes into the gun from under the trigger. but you stop it and then there is not leaks. no balls shoot out either. maybe one ball and then it just keeps firing really really fast bursts of air with no balls until i stop it by cocking it back then it stops.

Anys ideas for me?
 

·
Paintball?
Joined
·
7,646 Posts
Make sure your hammer oring is good (i.e. replace it) and clean and lube the internals
See of that helps, and if not, it might be something a bit harder to fix
 
1 - 2 of 2 Posts
Top