Paintball Guns and Gear forums banner

1 - 6 of 6 Posts

·
mil-simer
Joined
·
1,102 Posts
Discussion Starter #1
Today I went to the field to play after over 6 months of not playing. The first two or three games were good, but during the last game I ran out of air. Afterwards I learned that my marker actually leaked all of the air through the barrel. A Pro at the field that had which I believe was a Dye NT11 helped me out and we stripped the marker completeley and he claimed it was the poppet seal because all of the o-rings were perfect (We also tried firing the marker after greasing it completely. Then I went home and reasembled the marker there. I went through the manual and it said that the problem is either the solenoid being damaged or needing to be reset, or the poppet seal needs replacing. Then I came up with another problem, it seems that that the on/off button is not clicking after I tried to reassemble it. The button in the board does click but once I put the other marker's shell the on/off button doesn't click. I checked for obstuctions and I saw none.



That is the bolt from the inside, and it should be perfectly smooth but it's not. You can tell by the raised portions on it. The Pro guy at the field and the owner claimed that that was most probably the problem but I'm not sure. They also claimed that this happened because my marker wasn't used for so long and it wasn't ever lubed.

But first I have to know how to solve the on/off button problem first, any suggestions?
 

·
Administrator
Joined
·
23,657 Posts
what is a tm-15 based off of? a tippman?

What exactly are we looking at in this picture?

if the power button is working when the board is not installed, check to make sure the board isn't shorting out on the frame anywhere, then cut a piece a plastic and slide it between the switch and whatever you use to press the button when it's installed.
 

·
mil-simer
Joined
·
1,102 Posts
Discussion Starter #6
what is a tm-15 based off of? a tippman?

What exactly are we looking at in this picture?

if the power button is working when the board is not installed, check to make sure the board isn't shorting out on the frame anywhere, then cut a piece a plastic and slide it between the switch and whatever you use to press the button when it's installed.
The TM-15 is based on the Invert Mini. That in the picture is the poppet assembly, it should be a completely smooth surface but it has two rised bits inside which are the small black shapes inside the poppet valve, I don't know if you can actually identify it. I don't really think that is actually the problem since I don't see any reason why that should affect my marker. The guy that tried to fix it at the field used to his Dye NT11 and those, as he claimed, a mere scratch in one of the o-rings causes leaks.

Another thing I forgot to mention is that when inserted the tank after we dissassembled the marker we noticed that the solenoid moved forward and started to leak air. What I am suspecting is that it just needs to be reset. But I cannot do that until I fix the On/Off button problem. I'll take your advice Matrix and see if it works. It is weir what happened, since I've dissassembled the marker before and this has never happened before.
 
1 - 6 of 6 Posts
Top