Paintball Guns and Gear forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
i have the spidre imagine and its starting to really aggrivate me. i've heard that if the gun starts skipping shots that the batterey is out. well today i went pbing and i had a brand new batterey in it (9.0 volts). well anyways, i get there, and in like the second round, maybe like 500 shots at the most, it starts to shoot like every other shot/every three shots. well after that i was real pissed so i went and got another 9.0 volt and then it worked well for a while. well, maybe 500 balls later, it happens again so i dont know what the hell to do. does anybody have any idea on what could be wrong and what i can do to fix it. if theres a solution, do i have to bring it into a store, or can i just do it myself? Please help!! :confused:
 

·
Registered
Joined
·
783 Posts
I have an imagine too. These thingswill eat batteries like theres no tomorrow, i suggest getting a good rechargeable, mine actually came w/ one but i cant find the wire to charge it with :/
 

·
Registered
Joined
·
671 Posts
yea look for a java rechargeable there only like 19 something dollars with charger. i got sick of all of the 9volts.
 

·
Registered
Joined
·
4,618 Posts
i've had a 9 volt in mine since i bought it used from someone in february... still works.. i'd suggest tightening your trigger frame, if that doesnt work, check your velocity, no dice? check your sear/sear spring and hammer, if all else fails see if it's your solenoid...
 
1 - 4 of 4 Posts
Top